Well, there was an issue that talks about the incompatibility with Node 15.x for Telescope. Some of the dependencies crash without any reason when using npm install. Strange? Well, not really…

Anton’s Issue

npm 7.x has updated so that dependencies work differently when installed. The fix? Set “legacy-peer-dep” to true, and BAM! We’re back in service (at least until we overhaul our packages). How did I find out? Well, it was documented right here: https://github.com/npm/rfcs/blob/latest/implemented/0025-install-peer-deps.md

It’s quite a good read.